Quick install

Prerequirements

Good practice is to use nginx as frontend to your inner resources. You can install it from ubuntu\debian repository or use official nginx repositories https://nginx.org/en/linux_packages.html.

nginx example config:

server {
    listen [::]:80;
    listen 80;
    server_name wordpress.blindage.org;

    location / {
        proxy_pass http://wp:8080/;
        proxy_set_header X-Real-IP $remote_addr;
        proxy_set_header Host $host;
        proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
    }

}

Docker

Remove old docker versions:

sudo apt-get remove docker docker-engine docker.io

Install requirements and add ppa repo:

sudo apt-get update
sudo apt-get install \
    apt-transport-https \
    ca-certificates \
    curl \
    software-properties-common
curl -fsSL https://download.docker.com/linux/ubuntu/gpg | sudo apt-key add -
sudo add-apt-repository \
    "deb [arch=amd64] https://download.docker.com/linux/ubuntu \
    $(lsb_release -cs) \
    stable"
sudo apt-get update

Install last docker version:

sudo apt-get install docker-ce

docker-compose

Run this commands:

sudo curl -L https://github.com/docker/compose/releases/download/1.22.0/docker-compose-$(uname -s)-$(uname -m) -o /usr/local/bin/docker-compose
sudo chmod +x /usr/local/bin/docker-compose